Increased website latency
Incident Report for Bloom
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 01, 2018 - 18:41 PST
Identified
Due to high volumes of traffic, you may experience slower loads and intermittent connectivity issues
Posted over 1 year ago. Mar 01, 2018 - 16:03 PST